2016-01-14

msys2のgtkmmを利用する際はC++11以上でないとコンパイル・リンクに失敗する

msys2のgtkmmパッケージとgtkmm3パッケージで確認。

要するに、-std=c++11-std=c++14-std=gnu++11-std=gnu++14を付ける必要がある。

真面目にエラーメッセージを読んでないから原因は分からないが、どうも ABI が変わっちゃうからっぽい?

ひとつ上へ